import re
regex = re.compile(r"((?<=\s)\*(?P<common>[^\*]+?)\*(?=\s)|^\*(?P<uncommon>[^\*].*[^\*])\*$)", flags=re.MULTILINE)
test_str = "**part strong,** *part emphasized*"
subst = "<em>\\g<common>\\g<uncommon></em>"
result = regex.sub(subst, test_str)
if result:
print(result)