#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?<!\S)\\eqref(\{[^}]*\})"
Local $sString = "such as \eqref{e1} and \eqref{e2}."
Local $sSubst = "(\\ref$1)"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)