use strict;
my $str = 'such as \\eqref{e1} and \\eqref{e2}.';
my $regex = qr/(?<!\S)\\eqref(\{[^}]*\})/mp;
my $subst = '(\\\\ref$1)';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";