$re = '/(?<!\S)\\\\eqref(\{[^}]*\})/m';
$str = 'such as \\eqref{e1} and \\eqref{e2}.';
$subst = "(\\ref$1)";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;