import re
regex = re.compile(r"(?<!\S)\\eqref(\{[^}]*\})", flags=re.MULTILINE)
test_str = "such as \\eqref{e1} and \\eqref{e2}."
subst = "(\\\\ref$1)"
result = regex.sub(subst, test_str)
if result:
print(result)