const regex = /(?<!\S)\\eqref(\{[^}]*\})/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<!\\S)\\\\eqref(\\{[^}]*\\})', 'gm')
const str = `such as \\eqref{e1} and \\eqref{e2}.`;
const subst = `(\\ref$1)`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);