#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(http[s]?:\/\/www\.domain)(.*)(paramZ\=[\d]+)(.*)$"
Local $sString = "http://www.domain.com/?paramZ=123456" & @CRLF & _
"https://www.domain.com/?param1=val1;param2=val2;param3=val3;paramZ=123456" & @CRLF & _
"http://www.domain.com/one/or/more?paramZ=123456;param1=val1;param2=val2;param3=val3" & @CRLF & _
"https://www.domain.com/one/or/more?param1=val1;paramZ=123456;param2=val2;param3=val3" & @CRLF & _
"http://www.domain.com/one/or/more?param1=val1;param2=val2;param3=val3"
Local $sSubst = "$1$2paramZ=987654$4"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)