# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(http[s]?:\/\/www\.domain)(.*)(paramZ\=[\d]+)(.*)$"
test_str = ("http://www.domain.com/?paramZ=123456\n"
"https://www.domain.com/?param1=val1;param2=val2;param3=val3;paramZ=123456\n"
"http://www.domain.com/one/or/more?paramZ=123456;param1=val1;param2=val2;param3=val3\n"
"https://www.domain.com/one/or/more?param1=val1;paramZ=123456;param2=val2;param3=val3\n"
"http://www.domain.com/one/or/more?param1=val1;param2=val2;param3=val3")
subst = "$1$2paramZ=987654$4"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.