const regex = /^(http[s]?:\/\/www\.domain)(.*)(paramZ\=[\d]+)(.*)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(http[s]?:\\\/\\\/www\\.domain)(.*)(paramZ\\=[\\d]+)(.*)$', 'gm')
const str = `http://www.domain.com/?paramZ=123456
https://www.domain.com/?param1=val1;param2=val2;param3=val3;paramZ=123456
http://www.domain.com/one/or/more?paramZ=123456;param1=val1;param2=val2;param3=val3
https://www.domain.com/one/or/more?param1=val1;paramZ=123456;param2=val2;param3=val3
http://www.domain.com/one/or/more?param1=val1;param2=val2;param3=val3`;
const subst = `$1$2paramZ=987654$4`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);