import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(http[s]?:\\/\\/www\\.domain)(.*)(paramZ\\=[\\d]+)(.*)$";
final String string = "http://www.domain.com/?paramZ=123456\n"
+ "https://www.domain.com/?param1=val1;param2=val2;param3=val3;paramZ=123456\n"
+ "http://www.domain.com/one/or/more?paramZ=123456;param1=val1;param2=val2;param3=val3\n"
+ "https://www.domain.com/one/or/more?param1=val1;paramZ=123456;param2=val2;param3=val3\n"
+ "http://www.domain.com/one/or/more?param1=val1;param2=val2;param3=val3";
final String subst = "$1$2paramZ=987654$4";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}