#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^((\.?)|(\d)|(\d?\.\d{2}))$"
Local $sString = "1" & @CRLF & _
"1.1" & @CRLF & _
"1.11" & @CRLF & _
"0.00" & @CRLF & _
"0" & @CRLF & _
".00" & @CRLF & _
"222.222." & @CRLF & _
"2.234" & @CRLF & _
"12.343" & @CRLF & _
".34" & @CRLF & _
".3434" & @CRLF & _
"0.45567" & @CRLF & _
"aa" & @CRLF & _
"0a" & @CRLF & _
"a.987" & @CRLF & _
"76.hj" & @CRLF & _
"77.77" & @CRLF & _
"7.77" & @CRLF & _
"." & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")