// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^((\.?)|(\d)|(\d?\.\d{2}))$").unwrap();
let string = "1
1.1
1.11
0.00
0
.00
222.222.
2.234
12.343
.34
.3434
0.45567
aa
0a
a.987
76.hj
77.77
7.77
.
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}