import re
regex = re.compile(r"^((\.?)|(\d)|(\d?\.\d{2}))$", flags=re.MULTILINE)
test_str = ("1\n"
"1.1\n"
"1.11\n"
"0.00\n"
"0\n"
".00\n"
"222.222.\n"
"2.234\n"
"12.343\n"
".34\n"
".3434\n"
"0.45567\n"
"aa\n"
"0a\n"
"a.987\n"
"76.hj\n"
"77.77\n"
"7.77\n"
".\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")