use strict;
my $str = '1
1.1
1.11
0.00
0
.00
222.222.
2.234
12.343
.34
.3434
0.45567
aa
0a
a.987
76.hj
77.77
7.77
.
';
my $regex = qr/^((\.?)|(\d)|(\d?\.\d{2}))$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}