re = /^((\.?)|(\d)|(\d?\.\d{2}))$/m
str = '1
1.1
1.11
0.00
0
.00
222.222.
2.234
12.343
.34
.3434
0.45567
aa
0a
a.987
76.hj
77.77
7.77
.
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end