using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:[a-z]:)?(?:[\\\/][a-z0-9_. -]*)+$";
string input = @"C:\Deal\v6\.git\logs
C:\Deal\v6\
F:\Deal\v6\compil.log
F:/Deal/v6/comp-il.log
F:/De al/v6/compil.log
F:/De al/v6/comp il.log
/c/Deal/v6
/c/Deal/v6\
C:\
/
/c
\\dwi3342\Deal\v6\comp-il.log
//dwi3342/Deal/v6/compil.log
F:/Deal/../compil.log
GG:/Deal/v6/comp-il.log
^(.*\/)([^\/]*)$
((?:[^\/]*\/)*)(.*)
([\/\\][^\/\\]*$)
^(.*(?:\/|\\))([^\/\\]*)$
^((?:[^\/\\]*\/\\)*)(.*)$
^(?:[a-zA-Z]:[\\\/]|[\\\/])(?:[a-zA-Z0-9_. -]+[\\\/])*(?:[a-zA-Z0-9_. -]+)?$
^(?:[a-zA-Z]:)?(?:[\\\/][a-zA-Z0-9_. -]*)+$
";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}