const regex = /^(?:[a-z]:)?(?:[\\\/][a-z0-9_. -]*)+$/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:[a-z]:)?(?:[\\\\\\\/][a-z0-9_. -]*)+$', 'gmi')
const str = `C:\\Deal\\v6\\.git\\logs
C:\\Deal\\v6\\
F:\\Deal\\v6\\compil.log
F:/Deal/v6/comp-il.log
F:/De al/v6/compil.log
F:/De al/v6/comp il.log
/c/Deal/v6
/c/Deal/v6\\
C:\\
/
/c
\\\\dwi3342\\Deal\\v6\\comp-il.log
//dwi3342/Deal/v6/compil.log
F:/Deal/../compil.log
GG:/Deal/v6/comp-il.log
^(.*\\/)([^\\/]*)\$
((?:[^\\/]*\\/)*)(.*)
([\\/\\\\][^\\/\\\\]*\$)
^(.*(?:\\/|\\\\))([^\\/\\\\]*)\$
^((?:[^\\/\\\\]*\\/\\\\)*)(.*)\$
^(?:[a-zA-Z]:[\\\\\\/]|[\\\\\\/])(?:[a-zA-Z0-9_. -]+[\\\\\\/])*(?:[a-zA-Z0-9_. -]+)?\$
^(?:[a-zA-Z]:)?(?:[\\\\\\/][a-zA-Z0-9_. -]*)+\$
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}