// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)^(?:[a-z]:)?(?:[\\\/][a-z0-9_. -]*)+$").unwrap();
let string = "C:\\Deal\\v6\\.git\\logs
C:\\Deal\\v6\\
F:\\Deal\\v6\\compil.log
F:/Deal/v6/comp-il.log
F:/De al/v6/compil.log
F:/De al/v6/comp il.log
/c/Deal/v6
/c/Deal/v6\\
C:\\
/
/c
\\\\dwi3342\\Deal\\v6\\comp-il.log
//dwi3342/Deal/v6/compil.log
F:/Deal/../compil.log
GG:/Deal/v6/comp-il.log
^(.*\\/)([^\\/]*)$
((?:[^\\/]*\\/)*)(.*)
([\\/\\\\][^\\/\\\\]*$)
^(.*(?:\\/|\\\\))([^\\/\\\\]*)$
^((?:[^\\/\\\\]*\\/\\\\)*)(.*)$
^(?:[a-zA-Z]:[\\\\\\/]|[\\\\\\/])(?:[a-zA-Z0-9_. -]+[\\\\\\/])*(?:[a-zA-Z0-9_. -]+)?$
^(?:[a-zA-Z]:)?(?:[\\\\\\/][a-zA-Z0-9_. -]*)+$
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}