#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<!\d)(?:19|20)(?:\d{2}){2,}(?!\d)"
Local $sString = "202101310000-daily" & @CRLF & _
"my_merchant_df_20210129" & @CRLF & _
"1234567" & @CRLF & _
"12" & @CRLF & _
"1234" & @CRLF & _
"12345" & @CRLF & _
"1900" & @CRLF & _
"1900011" & @CRLF & _
"00210129"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")