const regex = /(?<!\d)(?:19|20)(?:\d{2}){2,}(?!\d)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<!\\d)(?:19|20)(?:\\d{2}){2,}(?!\\d)', 'gm')
const str = `202101310000-daily
my_merchant_df_20210129
1234567
12
1234
12345
1900
1900011
00210129`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}