using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!\d)(?:19|20)(?:\d{2}){2,}(?!\d)";
string input = @"202101310000-daily
my_merchant_df_20210129
1234567
12
1234
12345
1900
1900011
00210129";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}