use strict;
my $str = '202101310000-daily
my_merchant_df_20210129
1234567
12
1234
12345
1900
1900011
00210129';
my $regex = qr/(?<!\d)(?:19|20)(?:\d{2}){2,}(?!\d)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}