re = /(?<!\d)(?:19|20)(?:\d{2}){2,}(?!\d)/m
str = '202101310000-daily
my_merchant_df_20210129
1234567
12
1234
12345
1900
1900011
00210129'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end