#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^K?A?\d{1,2}\w{2}\d{3,4}\s|$"
Local $sString = "KA01MA566 " & @CRLF & _
"KA03BA877 8YKA39NF4333" & @CRLF & _
"" & @CRLF & _
"KF23BG0233" & @CRLF & _
"TN45MA0233" & @CRLF & _
"A02BA9445" & @CRLF & _
"02BA3455" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")