using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^K?A?\d{1,2}\w{2}\d{3,4}\s|$";
string input = @"KA01MA566
KA03BA877 8YKA39NF4333
KF23BG0233
TN45MA0233
A02BA9445
02BA3455
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}