// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^K?A?\d{1,2}\w{2}\d{3,4}\s|$").unwrap();
let string = "KA01MA566
KA03BA877 8YKA39NF4333
KF23BG0233
TN45MA0233
A02BA9445
02BA3455
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}