$re = '/^K?A?\d{1,2}\w{2}\d{3,4}\s|$/m';
$str = 'KA01MA566
KA03BA877 8YKA39NF4333
KF23BG0233
TN45MA0233
A02BA9445
02BA3455
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);