use strict;
my $str = 'KA01MA566
KA03BA877 8YKA39NF4333
KF23BG0233
TN45MA0233
A02BA9445
02BA3455
';
my $regex = qr/^K?A?\d{1,2}\w{2}\d{3,4}\s|$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}