#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^([АВЕКМНОРСТУХавекмнорстух]){1}\d{3}\1{2}\d{2,3}$"
Local $sString = "A555BA77" & @CRLF & _
"А555Вb65" & @CRLF & _
"t333yx179" & @CRLF & _
"а001аа177" & @CRLF & _
"" & @CRLF & _
"АВЕКМНОРСТУХ" & @CRLF & _
"ABEKMHOPCTYX" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")