import re
regex = re.compile(r"^([АВЕКМНОРСТУХавекмнорстух]){1}\d{3}\1{2}\d{2,3}$", flags=re.MULTILINE)
test_str = ("A555BA77\n"
"А555Вb65\n"
"t333yx179\n"
"а001аа177\n\n"
"АВЕКМНОРСТУХ\n"
"ABEKMHOPCTYX\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")