const regex = new RegExp('^([АВЕКМНОРСТУХавекмнорстух]){1}\\d{3}\\1{2}\\d{2,3}$', 'gm')
const str = `A555BA77
А555Вb65
t333yx179
а001аа177
АВЕКМНОРСТУХ
ABEKMHOPCTYX
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}