import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([АВЕКМНОРСТУХавекмнорстух]){1}\\d{3}\\1{2}\\d{2,3}$";
final String string = "A555BA77\n"
+ "А555Вb65\n"
+ "t333yx179\n"
+ "а001аа177\n\n"
+ "АВЕКМНОРСТУХ\n"
+ "ABEKMHOPCTYX\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}