#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=Company\s)([\s\S]+?)[\n\r]+Is selling the.+[\n\r]+(.+)[\n\r]+.+[\n\r]+(\d+).+?(\S+@\S+)"
Local $sString = "Company ABC" & @CRLF & _
"" & @CRLF & _
"Is selling the following scrap material" & @CRLF & _
"" & @CRLF & _
"EXCAVATION MACHINE" & @CRLF & _
"" & @CRLF & _
", interested buyers can contact" & @CRLF & _
"" & @CRLF & _
"17369999 or ABDULLA@CompanyABC.COM" & @CRLF & _
"" & @CRLF & _
"Company GGG" & @CRLF & _
"" & @CRLF & _
"Is selling the following scrap material" & @CRLF & _
"" & @CRLF & _
"Coaster BUS" & @CRLF & _
"" & @CRLF & _
", interested buyers can contact" & @CRLF & _
"" & @CRLF & _
"17123123 or TTT@CompanyGGG.COM" & @CRLF & _
"" & @CRLF & _
"Company DDD W.L.L" & @CRLF & _
"" & @CRLF & _
"And partners" & @CRLF & _
"" & @CRLF & _
"Is selling the following scrap material" & @CRLF & _
"" & @CRLF & _
"Boats Motors" & @CRLF & _
"" & @CRLF & _
", interested buyers can contact" & @CRLF & _
"" & @CRLF & _
"175654556 or Jeff@CompanyDDD.COM" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")