using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=Company\s)([\s\S]+?)[\n\r]+Is selling the.+[\n\r]+(.+)[\n\r]+.+[\n\r]+(\d+).+?(\S+@\S+)";
string input = @"Company ABC
Is selling the following scrap material
EXCAVATION MACHINE
, interested buyers can contact
17369999 or ABDULLA@CompanyABC.COM
Company GGG
Is selling the following scrap material
Coaster BUS
, interested buyers can contact
17123123 or TTT@CompanyGGG.COM
Company DDD W.L.L
And partners
Is selling the following scrap material
Boats Motors
, interested buyers can contact
175654556 or Jeff@CompanyDDD.COM
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}