import Foundation
let pattern = #"(?<=Company\s)([\s\S]+?)[\n\r]+Is selling the.+[\n\r]+(.+)[\n\r]+.+[\n\r]+(\d+).+?(\S+@\S+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Company ABC
Is selling the following scrap material
EXCAVATION MACHINE
, interested buyers can contact
17369999 or ABDULLA@CompanyABC.COM
Company GGG
Is selling the following scrap material
Coaster BUS
, interested buyers can contact
17123123 or TTT@CompanyGGG.COM
Company DDD W.L.L
And partners
Is selling the following scrap material
Boats Motors
, interested buyers can contact
175654556 or Jeff@CompanyDDD.COM
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)