$re = '/(?<=Company\s)([\s\S]+?)[\n\r]+Is selling the.+[\n\r]+(.+)[\n\r]+.+[\n\r]+(\d+).+?(\S+@\S+)/m';
$str = 'Company ABC
Is selling the following scrap material
EXCAVATION MACHINE
, interested buyers can contact
17369999 or ABDULLA@CompanyABC.COM
Company GGG
Is selling the following scrap material
Coaster BUS
, interested buyers can contact
17123123 or TTT@CompanyGGG.COM
Company DDD W.L.L
And partners
Is selling the following scrap material
Boats Motors
, interested buyers can contact
175654556 or Jeff@CompanyDDD.COM
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);