const regex = /(?<=Company\s)([\s\S]+?)[\n\r]+Is selling the.+[\n\r]+(.+)[\n\r]+.+[\n\r]+(\d+).+?(\S+@\S+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=Company\\s)([\\s\\S]+?)[\\n\\r]+Is selling the.+[\\n\\r]+(.+)[\\n\\r]+.+[\\n\\r]+(\\d+).+?(\\S+@\\S+)', 'gm')
const str = `Company ABC
Is selling the following scrap material
EXCAVATION MACHINE
, interested buyers can contact
17369999 or ABDULLA@CompanyABC.COM
Company GGG
Is selling the following scrap material
Coaster BUS
, interested buyers can contact
17123123 or TTT@CompanyGGG.COM
Company DDD W.L.L
And partners
Is selling the following scrap material
Boats Motors
, interested buyers can contact
175654556 or Jeff@CompanyDDD.COM
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}