#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)([^@]|^)(@(?!\.|[a-z\d.]+?\.(?![a-z\d]))[a-z\d.]+)"
Local $sString = "@test1 стоп, не так все" & @CRLF & _
"@test1 не знаю даже @test1 тест@test1привет @@test1р" & @CRLF & _
"Привет, ребят @test2 как дела? @test1 @test2@test1" & @CRLF & _
"@test1п" & @CRLF & _
"" & @CRLF & _
"1. Нужно исключить после @ точку (".") - @.test (исключить)" & @CRLF & _
"2. Нужно исключить повторение в середине точки (".") более 1 раза (> 1) - @test..test (исключить)" & @CRLF & _
"3. Нужно исключить точку в конце искомого выражения @test. (исключить)" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")