import Foundation
let pattern = #"([^@]|^)(@(?!\.|[a-z\d.]+?\.(?![a-z\d]))[a-z\d.]+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"""
@test1 стоп, не так все
@test1 не знаю даже @test1 тест@test1привет @@test1р
Привет, ребят @test2 как дела? @test1 @test2@test1
@test1п
1. Нужно исключить после @ точку (".") - @.test (исключить)
2. Нужно исключить повторение в середине точки (".") более 1 раза (> 1) - @test..test (исключить)
3. Нужно исключить точку в конце искомого выражения @test. (исключить)
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)