import re
regex = re.compile(r"([^@]|^)(@(?!\.|[a-z\d.]+?\.(?![a-z\d]))[a-z\d.]+)", flags=re.IGNORECASE)
test_str = ("@test1 стоп, не так все\n"
"@test1 не знаю даже @test1 тест@test1привет @@test1р\n"
"Привет, ребят @test2 как дела? @test1 @test2@test1\n"
"@test1п\n\n"
"1. Нужно исключить после @ точку (\".\") - @.test (исключить)\n"
"2. Нужно исключить повторение в середине точки (\".\") более 1 раза (> 1) - @test..test (исключить)\n"
"3. Нужно исключить точку в конце искомого выражения @test. (исключить)\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")