re = /([^@]|^)(@(?!\.|[a-z\d.]+?\.(?![a-z\d]))[a-z\d.]+)/i
str = '@test1 стоп, не так все
@test1 не знаю даже @test1 тест@test1привет @@test1р
Привет, ребят @test2 как дела? @test1 @test2@test1
@test1п
1. Нужно исключить после @ точку (".") - @.test (исключить)
2. Нужно исключить повторение в середине точки (".") более 1 раза (> 1) - @test..test (исключить)
3. Нужно исключить точку в конце искомого выражения @test. (исключить)
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end