const regex = /([^@]|^)(@(?!\.|[a-z\d.]+?\.(?![a-z\d]))[a-z\d.]+)/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([^@]|^)(@(?!\\.|[a-z\\d.]+?\\.(?![a-z\\d]))[a-z\\d.]+)', 'gi')
const str = `@test1 стоп, не так все
@test1 не знаю даже @test1 тест@test1привет @@test1р
Привет, ребят @test2 как дела? @test1 @test2@test1
@test1п
1. Нужно исключить после @ точку (".") - @.test (исключить)
2. Нужно исключить повторение в середине точки (".") более 1 раза (> 1) - @test..test (исключить)
3. Нужно исключить точку в конце искомого выражения @test. (исключить)
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}