# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/customers(?=(?:[^><]*<[^<>]*>)*[^><]*$)/<span style='color: red;'>class<span>/gm;t' <<< "<p class=\"Pa0\" style=\"margin: 0in 0in 0pt;\"><span class=\"A1\"><span style=\"font-size: 10pt;\">Giving this flyer to your class customers</span></span></p>
"