const regex = /customers(?=(?:[^><]*<[^<>]*>)*[^><]*$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('customers(?=(?:[^><]*<[^<>]*>)*[^><]*$)', 'gm')
const str = `<p class="Pa0" style="margin: 0in 0in 0pt;"><span class="A1"><span style="font-size: 10pt;">Giving this flyer to your class customers</span></span></p>
`;
const subst = `<span style='color: red;'>class<span>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);