use strict;
my $str = '<p class="Pa0" style="margin: 0in 0in 0pt;"><span class="A1"><span style="font-size: 10pt;">Giving this flyer to your class customers</span></span></p>
';
my $regex = qr/customers(?=(?:[^><]*<[^<>]*>)*[^><]*$)/mp;
my $subst = '<span style=\'color: red;\'>class<span>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";