using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"{\""orgCd\"":\""\d*_123_-*\d*\"",\""isDistributor\"":0}";
string input = @"{""orgCd"":""1234_123_123"",""isDistributor"":0}";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}