// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m){\"orgCd\":\"\d*_123_-*\d*\",\"isDistributor\":0}"#).unwrap();
let string = "{\"orgCd\":\"1234_123_123\",\"isDistributor\":0}";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}