package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m){\"orgCd\":\"\d*_123_-*\d*\",\"isDistributor\":0}`)
var str = `{"orgCd":"1234_123_123","isDistributor":0}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}