$re = '/{\"orgCd\":\"\d*_123_-*\d*\",\"isDistributor\":0}/m';
$str = '{"orgCd":"1234_123_123","isDistributor":0}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);