re = /{\"orgCd\":\"\d*_123_-*\d*\",\"isDistributor\":0}/m
str = '{"orgCd":"1234_123_123","isDistributor":0}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end